Canuck Audio Mart Hifi and Audio ForumCanuck Audio Mart Hifi and Audio Forum
It is currently Thu Dec 14, 2017 4:54 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Mon Nov 20, 2017 2:23 pm 
Offline

Joined: Wed Jul 09, 2014 9:52 am
Posts: 44
Location: kelowna, BC, CA
I just acquired these mission 770 locally with matching stands. They worked fine with the AA battery test at sellers. So I bought them. I opened them up for a recap job when I got home and found that somebody altered the crossover. A cap was disconnected parts were added. Here's some pics can anyone help me get these close to factory wiring.

Attachment:
20171120_125226.jpg
20171120_125226.jpg [ 278.41 KiB | Viewed 613 times ]

Attachment:
20171120_124530.jpg
20171120_124530.jpg [ 141.2 KiB | Viewed 613 times ]
Attachment:
20171120_125314.jpg
20171120_125314.jpg [ 178.06 KiB | Viewed 613 times ]


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 3:03 pm 
Offline

Joined: Sun Apr 05, 2009 7:06 pm
Posts: 990
Location: hawkesbury, ON, CA
seems he only difference is that 2.1 uf capacitors was disconnected. if that is the case , you have to ask yourself why. it might be shorted or bad thus why previous owner unplugged it. if it is ok then just reweld it. right now they use both capacitor in parralel so they add up to 10 uf + 2.1 uf = 12.1 uf so now it is only 10 uf because the 2.1 uf disconnected according to the 2 diagram you show, resistance are identicle, what are the change you say where done?


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 3:26 pm 
Offline

Joined: Wed Jul 09, 2014 9:52 am
Posts: 44
Location: kelowna, BC, CA
The new white glue is where the non-oem parts are stuck. Both caps that were disconnected tested good. It's looks like an inductor was added with a few resistors.

Here my guess to the factory wiring job. Unsure of high pass wiring

Attachment:
20171120_151533.jpg
20171120_151533.jpg [ 154.74 KiB | Viewed 561 times ]


Last edited by KING OF AUDIO on Mon Nov 20, 2017 6:47 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 3:56 pm 
Offline

Joined: Sun Apr 05, 2009 7:06 pm
Posts: 990
Location: hawkesbury, ON, CA
did both xover have those extra coils added.the coils is there for tweeter to make it a 12/d/b oct. second order if there was none on original xover, then they where maybe only 6 d/b oct. are all driver original. if driver where change, xover change might have been done to accommodate new drivers. or simply xover modified to improve overall sound.
but judging by the xover layout. seems there was already 3 coils in circuit. maybe coil came loose with vibration. and owner try to patch it up , without noticing capacitor disconnected??? I would start by just weld capacitor in place. and listen how it sound.
the best would be to get a schematic and check back both xover for modification.


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 5:06 pm 
Offline

Joined: Wed Jul 09, 2014 9:52 am
Posts: 44
Location: kelowna, BC, CA
Drivers are original. The cap was purposely taken out of circuit as you can see it was cut. This is a 770s crossover from the internet from diyaudio. Some differences for sure.
Attachment:
20171120_170053.jpg
20171120_170053.jpg [ 158.62 KiB | Viewed 506 times ]

Attachment:
index-3.jpg
index-3.jpg [ 35.29 KiB | Viewed 506 times ]
Attachment:
20171120_130256.jpg
20171120_130256.jpg [ 161.83 KiB | Viewed 506 times ]


Last edited by KING OF AUDIO on Mon Nov 20, 2017 6:31 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 5:38 pm 
Offline
User avatar

Joined: Wed Apr 28, 2010 2:00 pm
Posts: 3018
Location: Rio Rancho, NM, US
Hope you get them squared away. They are fantastic speakers, even by today's standards. I had a pair many years ago.

Was the seller the original owner? If so then a pox on him for selling the speakers in that condition without full disclosure. Why do I have a feeling it was a Kijiji sale?

_________________
I think, therefore I am not sure.


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 6:20 pm 
Offline

Joined: Sun Apr 05, 2009 7:06 pm
Posts: 990
Location: hawkesbury, ON, CA
you want them like the original then you will need to keep the 2 original coils, and get the right capacitor value, and might as well buy new capacitor to replace the old ones, I would also change resistance to mill specs, much better sound and 2% values insteed of 10% maybe $40 worth of parts. at less it was not a complicated xover, as long as you know the uf values.


Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 20, 2017 7:03 pm 
Offline

Joined: Wed Jul 09, 2014 9:52 am
Posts: 44
Location: kelowna, BC, CA
hifijones wrote:
Was the seller the original owner? If so then a pox on him for selling the speakers in that condition without full disclosure. Why do I have a feeling it was a Kijiji sale?


It was from one those facebook buy and sell groups. Original owner without a doubt the ad with his fb profile matches the original bill of sale. (Removed his name from bill of sale). These were expensive speakers for 1986. All I did was a AA battery test upon purchase for $90 confirming drivers passed current. Also they came with the sometimes missing stands.

The situation is frustrating but not much i can do about it.

Attachment:
20171120_131536.jpg
20171120_131536.jpg [ 260.86 KiB | Viewed 442 times ]


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 21, 2017 11:32 am 
Offline
User avatar

Joined: Wed Apr 28, 2010 2:00 pm
Posts: 3018
Location: Rio Rancho, NM, US
KING OF AUDIO wrote:
All I did was a AA battery test upon purchase for $90 confirming drivers passed current. Also they came with the sometimes missing stands.


$90.00 with stands? Oh you absolutely stole 'em. Once you get the crossover issues sorted out you will be a happy man. Hopefully it won't cost much to bring them back to spec.

_________________
I think, therefore I am not sure.


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 21, 2017 6:57 pm 
Offline
Dealer/Sponsor

Joined: Tue Jun 14, 2016 8:33 am
Posts: 1182
Location: Kingston, ON, CA
AFIK, those drivers are not stock originals. They never appeared together in a 770 box.

took a deeper interwebs look.

I stand corrected.

it's the 'S' part that fooled me. 770.....S.

so...audax sourced tweeter (?) and possibly an ELAC sourced custom woofer, by the looks of it.

_________________
(Ken Hotte, of) Teo Audio


Top
 Profile  
Reply with quote  
PostPosted: Tue Nov 21, 2017 7:23 pm 
Offline
User avatar

Joined: Wed Apr 28, 2010 2:00 pm
Posts: 3018
Location: Rio Rancho, NM, US
Here's a pair of 770s' from the early '80s, the 1st version I believe. Tweeters were SEAS ferrofluid.
Attachment:
615751-original_mission_770_loudspeakers_british_classics.jpg
615751-original_mission_770_loudspeakers_british_classics.jpg [ 311.41 KiB | Viewed 205 times ]

_________________
I think, therefore I am not sure.


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 22, 2017 1:51 am 
Offline

Joined: Wed Jul 09, 2014 9:52 am
Posts: 44
Location: kelowna, BC, CA
Plz note the picture order ain't right



Ok thanks to audio karma I can confirm this is the factory crossover.

Attachment:
index-3.jpg
index-3.jpg [ 35.29 KiB | Viewed 178 times ]


Then from diy audio which is another confirmation

Attachment:
20171121_205641.jpg
20171121_205641.jpg [ 173.61 KiB | Viewed 178 times ]


Which basically double confirms it.

Then I discovered this cut below the inductor wire. A wire that should be connected according to those pictures. Which triple backs up that those pictures is how it's supposed to be wired.

Attachment:
20171121_205147.jpg
20171121_205147.jpg [ 216.75 KiB | Viewed 177 times ]


I just need to the the values of the resistors and I'm sure I can salvage it.

-- 22 Nov 2017 09:55 --

This is how mine looks. I started disconnecting wires.
Attachment:
20171121_205147.jpg
20171121_205147.jpg [ 216.75 KiB | Viewed 177 times ]


Attachments:
index-5.jpg
index-5.jpg [ 67.38 KiB | Viewed 178 times ]
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group