Canuck Audio Mart Hifi and Audio Forum
http://www.canuckaudiomart.com/forum/

Another A/V receiver dies on me.
http://www.canuckaudiomart.com/forum/viewtopic.php?f=15&t=47366
Page 2 of 6

Author:  mahatma1 [ Fri Aug 04, 2017 6:26 am ]
Post subject:  Re: Another A/V receiver dies on me.

I use a variety of HDMI cables most bought from Amazon. All are 6 or 8 footers.
Although I wouldn't discount the Rogers box (HD4642) as a potential problem, I have to wonder if it was storm related.
A fairly loud noisy one blew through last night, then again every other electrical device is just fine.
:?

Author:  Hal Brian [ Fri Aug 04, 2017 6:35 am ]
Post subject:  Re: Another A/V receiver dies on me.

once a power surge wrecked my router, but didn't harm anything else in the house.....

Author:  L-Man [ Fri Aug 04, 2017 6:35 am ]
Post subject:  Re: Another A/V receiver dies on me.

Mahatma: check your private messages.

Author:  kolwrath [ Fri Aug 04, 2017 6:45 am ]
Post subject:  Re: Another A/V receiver dies on me.

mahatma1 wrote:
kolwrath wrote:
Seems odd that in each case it was the HDMI board that died.
What are you plugging into the HDMI ports on these things?

Edit: What I am suggesting is one of your display devices or sources might be bad and is the source of your issue.

I have a Rogers STB, Blu-ray player and the TV screen. That's it.
Everything else is working.

Ok thats really weird. I would agree with other posters that you should swap out the Rogers STB. Feel like were grasping straws here but its worth a shot.

Obligatory dumb questions:

1. Are your hdmi cables brand name or cheap as chips no-name?

2. How much clearance do you have above your reciever? is is there sufficient airflow around it? or is it in a closet/shelf behind a door?

3. is everything behind a line-conditioner?

Sorry for the dumb questions ... really not sure what could be going on here. Having the hdmi boards on all of em die is very suspect though.

Really wish you luck on fixing the problem ... I would be at wits end after so many receiver deaths :(

Author:  mahatma1 [ Fri Aug 04, 2017 6:52 am ]
Post subject:  Re: Another A/V receiver dies on me.

kolwrath wrote:
mahatma1 wrote:
kolwrath wrote:
Seems odd that in each case it was the HDMI board that died.
What are you plugging into the HDMI ports on these things?

Edit: What I am suggesting is one of your display devices or sources might be bad and is the source of your issue.

I have a Rogers STB, Blu-ray player and the TV screen. That's it.
Everything else is working.

Ok thats really weird. I would agree with other posters that you should swap out the Rogers STB. Feel like were grasping straws here but its worth a shot.

Obligatory dumb questions:

1. Are your hdmi cables brand name or cheap as chips no-name?

2. How much clearance do you have above your reciever? is is there sufficient airflow around it? or is it in a closet/shelf behind a door?

3. is everything behind a line-conditioner?

Sorry for the dumb questions ... really not sure what could be going on here. Having the hdmi boards on all of em die is very suspect though.

Really wish you luck on fixing the problem ... I would be at wits end after so many receiver deaths :(

No dumb questions. I appreciate the thought being put into this puzzle.
1. Cheap Amazon cables. Two of them Accel locking HDMI. Tried them on other HDMI inputs and they work.
2. Nothing above it. Wide open.
3. Everything plugged into a APC H10 also a Blue Circle Yalu Balula on the circuit.

Author:  planetofsound [ Fri Aug 04, 2017 7:12 am ]
Post subject:  Re: Another A/V receiver dies on me.

mahatma1 wrote:
As the subject line says another A/V receiver has died on me. More accurately the HDMI board has died yet again.
This morning I had audio but no video. After futzing around I verified that it was the receiver (Marantz NR 1403) that has screwed up.
In no particular order I have had the following A/V units fail:
Denon 3310 (the worst of the worst, abysmal non existant service) multiple HDMI failures. Denon washed their hands of it.
Onkyo Integra DTR 40.2 - multiple HDMI board failures. Slowest and most inept repairs ever.
Sony (don't know model) lasted about 2 weeks. HDMI board failure. They wanted more than the unit was worth to repair it.
Yamaha- HDMI failure, got incredibly hot and shut down constantly. Repairs cost more than the unit. I gave it away to my nieces kid. It failed totally two weeks later.
Marantz NR 1403- multiple HDMI failures, including the most recent one that makes three.
These units failed despite taking all kinds of measures to protect them from power surges,heat etc. (APC H10, Yalu Balula, fans, in line cable surge arrestors etc.).
And here we are again. :evil: :evil: :evil:


Agree with all your experience, however after 7 years we've never had a Marantz with HDMI failure, in general they are very reliable, 3 year warranty etc. As other posters have said, seems as though you have some kind of stray voltage on your HDMI cable. Are you in a lightning prone area? Is there a short in your cable line between ground and signal?

Author:  mahatma1 [ Fri Aug 04, 2017 7:23 am ]
Post subject:  Re: Another A/V receiver dies on me.

planetofsound wrote:
mahatma1 wrote:
As the subject line says another A/V receiver has died on me. More accurately the HDMI board has died yet again.
This morning I had audio but no video. After futzing around I verified that it was the receiver (Marantz NR 1403) that has screwed up.
In no particular order I have had the following A/V units fail:
Denon 3310 (the worst of the worst, abysmal non existant service) multiple HDMI failures. Denon washed their hands of it.
Onkyo Integra DTR 40.2 - multiple HDMI board failures. Slowest and most inept repairs ever.
Sony (don't know model) lasted about 2 weeks. HDMI board failure. They wanted more than the unit was worth to repair it.
Yamaha- HDMI failure, got incredibly hot and shut down constantly. Repairs cost more than the unit. I gave it away to my nieces kid. It failed totally two weeks later.
Marantz NR 1403- multiple HDMI failures, including the most recent one that makes three.
These units failed despite taking all kinds of measures to protect them from power surges,heat etc. (APC H10, Yalu Balula, fans, in line cable surge arrestors etc.).
And here we are again. :evil: :evil: :evil:


Agree with all your experience, however after 7 years we've never had a Marantz with HDMI failure, in general they are very reliable, 3 year warranty etc. As other posters have said, seems as though you have some kind of stray voltage on your HDMI cable. Are you in a lightning prone area? Is there a short in your cable line between ground and signal?

SW Ontario is very lightning prone. I don't believe there is a short. When I upgraded from fuses to breakers I had them pay extra attention to the grounding. Also recent road construction mandated a check up of my electrical and it was given a clean bill of health.
I'm still puzzled as to why only the A/V receivers fail. I have a lot of other audio gear that has no issue what so ever.

Author:  Chipmunk1957 [ Fri Aug 04, 2017 7:41 am ]
Post subject:  Re: Another A/V receiver dies on me.

http://www.canuckaudiomart.com/details/ ... em-avm-30/

Author:  L-Man [ Fri Aug 04, 2017 7:46 am ]
Post subject:  Re: Another A/V receiver dies on me.

Just saw that ad ... I bought an AVM40 not long ago and really enjoy it. It has the sound of a good 2-channel preamp but bass management, surround, etc.....

But does the OP have a power amp?

Author:  Chipmunk1957 [ Fri Aug 04, 2017 7:57 am ]
Post subject:  Re: Another A/V receiver dies on me.

I don't know but he says hes open to suggestions.

Author:  brownslane [ Fri Aug 04, 2017 8:02 am ]
Post subject:  Re: Another A/V receiver dies on me.

I have not run into the same problems you have, but I made a shift in power supply in my most recent system build; I went from power conditioners to a full battery backup system. In my neighborhood there are constant spikes, surges and outright power failures as there is massive and continual reconstruction of monster homes going on. I fried a really good and respected power conditioner a couple of months ago....I installed an |A|PC battery backup....good for over an hour, so I never get as much as a flicker....

Back to your point the the AVR boards are frying; this is unusual and may well be related to all the failures...check your memory; what components have been used in conjunction with all of the failed units? The HDMI cables? The Rogers box? Whatever components have been carried over need to be replaced. It does not take much to fry a board....

Best of luck.

Author:  mahatma1 [ Fri Aug 04, 2017 8:03 am ]
Post subject:  Re: Another A/V receiver dies on me.

I have several amps. Holy Crap. The Anthem looks awesome but I don't have a pilots license.

Author:  Mr.Hi-Fi [ Fri Aug 04, 2017 8:10 am ]
Post subject:  Re: Another A/V receiver dies on me.

I suggest changing the Rogers box OR at least use the component video and toslink feed from it instead of the HDMI.
Your hdmi problems are not typical of current AVR's.

Author:  Chipmunk1957 [ Fri Aug 04, 2017 8:11 am ]
Post subject:  Re: Another A/V receiver dies on me.

Well Mathatma...
If you don't have fear of flying i would def pick it up.

Author:  Quadzilla [ Fri Aug 04, 2017 8:13 am ]
Post subject:  Re: Another A/V receiver dies on me.

Chipmunk1957 wrote:
Well Mathatma...
If you don't have fear of flying i would def pick it up.


... and if I had his luck with these things, I wouldn't spend a lot of money on a replacement until I was sure that the problem was fixed.

I would get a $50 kijiji special and use it as a canary.

Page 2 of 6 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/