Canuck Audio Mart Hifi and Audio ForumCanuck Audio Mart Hifi and Audio Forum
It is currently Fri Dec 15, 2017 8:10 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Apr 08, 2015 10:05 am 
Offline

Joined: Mon Sep 15, 2014 10:28 pm
Posts: 3
Location: Carrying Place, ON, CA
I have an STA-2500 (impossible to find schematics for, but the STA2600 is almost identical inside, even for the part numbers/locations like C608 on one, is C608 on the other)

It arrived with some fairly serious issues - power meter not working / maxed out permanently and no output.

I have everything working beautifully now, except for an odd issue with the tone board.
The bass/mid/treble all work, as well as the tone defeat button - but the loudness, sub filter and high filter do nothing.
I have a feeling it could be the UPC4570 but it seems to me that this would affect other aspects of the amp too.
I found the chip on ebay, and ordered one, but I am hoping maybe someone here is familiar with this unit (as it was quite popular back in the early 80's) and might shed some light.


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 08, 2015 10:59 am 
Offline
User avatar

Joined: Thu Aug 18, 2005 3:44 pm
Posts: 625
Location: Repentigny, QC, CA
STA-2500 is a Realistic product ??
Preamp issue filter section, have you check if a voltage regulator for this section is defective?
wiring ? pc board trace? switch? cold joint?
good luck.


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 08, 2015 4:07 pm 
Offline

Joined: Thu Jan 13, 2011 11:29 am
Posts: 500
Location: St.Catharines, ON, CA
I just downloaded the STA-2600 schematic.
Send me email if you need it.

Those filters are all passive components switched into the existing tone control circuit.
I'm guessing a bad ground connection.

Gary


Top
 Profile  
Reply with quote  
PostPosted: Sun Sep 03, 2017 12:35 pm 
Offline

Joined: Sun Sep 03, 2017 12:17 pm
Posts: 1
Location: Reno, NV, US
Does anyone know what SuperTechIT did to fix the first problem he had with this amp?

"It arrived with some fairly serious issues - power meter not working / maxed out permanently and no output."

I'm having the exact same problem. I love my amp but I'm still fairly ill-knowledged about complex amplifier repair.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group